Notifications are delayed
Resolved
Oct 30 at 01:11pm MDT
The underlying issue has been fixed. Any notifications generated between 2025-10-29 19:00 UTC and 2025-10-30 19:15 UTC may not be delivered. If new workers were invited during this time period, you may need to re-send onboarding emails to these workers. Please feel free to reach out to our customer support team if you have any further questions or concerns. Thank you for your patience!
Affected services
Updated
Oct 30 at 12:44pm MDT
We have identified the root cause of the issue and we are working on a fix. Thank you for your patience!
Affected services
Created
Oct 30 at 12:00pm MDT
We are investigating an issue with delayed notifications. Onboarding notifications, account update alerts, and other notifications are affected.
Affected services