Back to overview
Degraded

Pay Card Service Degradation

Aug 21 at 12:40pm MDT
Affected services
API
Mobile App

Resolved
Aug 21 at 02:32pm MDT

Our vendor has informed us that the issue has been resolved. We appreciate your patience during this time and we sincerely apologize for any inconvenience caused!

Created
Aug 21 at 12:40pm MDT

Our Pay Card servicing provider is currently experiencing an ongoing incident that may affect our users. As a result, users may encounter difficulties signing up for a Pay Card, viewing transactions in the mobile app, and performing transfers to a bank account. The vendor has acknowledged the issue and is actively working on a fix.

We recognize the significance of our Pay Card services and sincerely apologize for any inconvenience this may cause. Our dedicated teams are diligently monitoring the situation and collaborating closely with our vendor to resolve the issue promptly.